aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 1d49aca..4628e44 100644
--- a/configure.in
+++ b/configure.in
@@ -1,11 +1,11 @@
# Process this file with autoconf to produce a configure script.
AC_INIT
-AM_INIT_AUTOMAKE(powwow, 1.2.10)
+AM_INIT_AUTOMAKE(powwow, 1.2.11)
AC_ARG_ENABLE(vt100,
AC_HELP_STRING([--enable-vt100],
[Hard code vt100 escape sequences, use if you have no termcap ]),
- AC_DEFINE(VT100))
+ AC_DEFINE(USE_VT100))
AC_ARG_ENABLE(sort,
AC_HELP_STRING([--enable-sort],
@@ -45,7 +45,8 @@ AC_CHECK_LIB(dl,dlopen,
# Checks for header files.
AC_CHECK_HEADERS([stdlib.h unistd.h])
-AC_CHECK_HEADER(locale.h,AC_DEFINE(USE_LOCALE))
+AC_CHECK_HEADER([locale.h],
+ [AC_CHECK_FUNC([putwc],[AC_DEFINE(USE_LOCALE)])])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST