aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGustav HÃ¥llberg <gustav@gmail.com>2009-01-01 02:01:59 (GMT)
committerGustav HÃ¥llberg <gustav@gmail.com>2009-01-16 23:40:21 (GMT)
commit9e30f88e70f6416c50d3fe3e41f6cbc3748c7c14 (patch)
treee08cba376a8303ac4064798a77a5af45e1f70eff /configure.in
parente2e2bd5c64f4d59062245c3e6b2c2ed4ed565cca (diff)
downloadpowwow-9e30f88e70f6416c50d3fe3e41f6cbc3748c7c14.zip
powwow-9e30f88e70f6416c50d3fe3e41f6cbc3748c7c14.tar.gz
powwow-9e30f88e70f6416c50d3fe3e41f6cbc3748c7c14.tar.bz2
support ./configure --disable-FEATURE
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 23 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index aea52e3..891fa09 100644
--- a/configure.in
+++ b/configure.in
@@ -4,29 +4,44 @@ AM_INIT_AUTOMAKE(powwow, 1.2.13)
AC_ARG_ENABLE(vt100,
AC_HELP_STRING([--enable-vt100],
- [Hard code vt100 escape sequences, use if you have no termcap ]),
- AC_DEFINE(USE_VT100))
+ [Hard code VT100 escape sequences; use if you have no termcap ]),
+ [case "${enableval}" in
+ yes) AC_DEFINE(USE_VT100) ;;
+ no) ;;
+ esac])
AC_ARG_ENABLE(sort,
AC_HELP_STRING([--enable-sort],
[Sort aliases and actions]),
- AC_DEFINE(DO_SORT))
+ [case "${enableval}" in
+ yes) AC_DEFINE(DO_SORT) ;;
+ no) ;;
+ esac])
AC_ARG_ENABLE(noshell,
AC_HELP_STRING([--enable-noshell],
[Disables the "#!" command]),
- AC_DEFINE(NO_SHELL))
+ [case "${enableval}" in
+ yes) AC_DEFINE(NO_SHELL) ;;
+ no) ;;
+ esac])
AC_ARG_ENABLE(ansibug,
AC_HELP_STRING([--enable-ansibug],
- [enables fixes for "#mark" ansi bugs on some terminals]),
- AC_DEFINE(BUG_ANSI))
+ [Enables fixes for "#mark" ansi bugs on some terminals]),
+ [case "${enableval}" in
+ yes) AC_DEFINE(BUG_ANSI) ;;
+ no) ;;
+ esac])
AC_ARG_ENABLE(bsd,
AC_HELP_STRING([--enable-bsd],
[Needed for BSD systems, in powwow this was USE_SGTTY and BSD_LIKE]),
- AC_DEFINE(USE_SGTTY)
- AC_DEFINE(BSD_LIKE))
+ [case "${enableval}" in
+ yes) AC_DEFINE(USE_SGTTY)
+ AC_DEFINE(BSD_LIKE) ;;
+ no) ;;
+ esac])
# Checks for programs.
AC_PROG_CC