aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorKalev Lember <kalev@smartlink.ee>2009-04-08 18:52:00 (GMT)
committerKalev Lember <kalev@smartlink.ee>2009-04-08 19:02:16 (GMT)
commitaec1eece73b0446201b00f916724c27f0a85e45b (patch)
treef879d7a027b56329b3d2a10e0c6262003a78f75c /configure.in
parent9410f5ad102904863ab9e70930437c573c46961e (diff)
downloadpowwow-aec1eece73b0446201b00f916724c27f0a85e45b.zip
powwow-aec1eece73b0446201b00f916724c27f0a85e45b.tar.gz
powwow-aec1eece73b0446201b00f916724c27f0a85e45b.tar.bz2
configure.in: Display summary at the end of configure run.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in72
1 files changed, 52 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index e9f5636..7a8c660 100644
--- a/configure.in
+++ b/configure.in
@@ -6,35 +6,39 @@ AC_CANONICAL_HOST
AC_ARG_ENABLE(vt100,
AC_HELP_STRING([--enable-vt100],
- [Hard code VT100 escape sequences; use if you have no termcap ]),
- [case "${enableval}" in
- yes) AC_DEFINE(USE_VT100) ;;
- no) ;;
- esac])
+ [Hard code VT100 escape sequences; use if you have no termcap [[default=no]]]),
+ ,
+ [enable_vt100="no"]
+)
+AS_IF([ test "${enable_vt100}" = yes ],
+ [ AC_DEFINE(USE_VT100) ])
AC_ARG_ENABLE(sort,
AC_HELP_STRING([--enable-sort],
- [Sort aliases and actions]),
- [case "${enableval}" in
- yes) AC_DEFINE(DO_SORT) ;;
- no) ;;
- esac])
+ [Sort aliases and actions [[default=no]]]),
+ ,
+ [enable_sort="no"]
+)
+AS_IF([ test "${enable_sort}" = yes ],
+ [ AC_DEFINE(DO_SORT) ])
AC_ARG_ENABLE(noshell,
AC_HELP_STRING([--enable-noshell],
- [Disables the "#!" command]),
- [case "${enableval}" in
- yes) AC_DEFINE(NO_SHELL) ;;
- no) ;;
- esac])
+ [Disables the "#!" command [[default=no]]]),
+ ,
+ [enable_noshell="no"]
+)
+AS_IF([ test "${enable_noshell}" = yes ],
+ [ AC_DEFINE(NO_SHELL) ])
AC_ARG_ENABLE(ansibug,
AC_HELP_STRING([--enable-ansibug],
- [Enables fixes for "#mark" ansi bugs on some terminals]),
- [case "${enableval}" in
- yes) AC_DEFINE(BUG_ANSI) ;;
- no) ;;
- esac])
+ [Enables fixes for "#mark" ansi bugs on some terminals [[default=no]]]),
+ ,
+ [enable_ansibug="no"]
+)
+AS_IF([ test "${enable_ansibug}" = yes ],
+ [ AC_DEFINE(BUG_ANSI) ])
AC_ARG_ENABLE(bsd,
AC_HELP_STRING([--enable-bsd],
@@ -97,3 +101,31 @@ AC_FUNC_MALLOC
AC_CHECK_FUNCS([bzero])
AC_OUTPUT(Makefile)
+
+AC_OUTPUT
+
+cat <<EOF
+
+
+Powwow has been configured with the following options:
+
+Version: ${VERSION}
+User binaries: $(eval eval eval echo "${bindir}")
+Data directory: $(eval eval eval echo "${datadir}/${PACKAGE}")
+
+enable-vt100: ${enable_vt100}
+enable-sort: ${enable_sort}
+enable-noshell: ${enable_noshell}
+enable-ansibug: ${enable_ansibug}
+enable-bsd: ${enable_bsd}
+
+Man page encoding: ${MAN_PAGE_ENCODING}
+
+Host: ${host}
+Compiler: ${CC}
+Preprocessor flags: ${CPPFLAGS}
+Compiler flags: ${CFLAGS}
+Linker flags: ${LDFLAGS}
+Libraries: ${LIBS}
+
+EOF